Getting started with Ångström

As described in the Ångström web page:

 Ångström is an effort to make a stable and userfriendly distribution for embedded devices like handhelds, set top boxes and network-attached storage devices and more.

 

A great tool for embedded engineers and the one that will be used through the beagle-ros project. Getting started with it is actually quite straight forward. You just need to have bitbake in your computer and run:

git clone git://github.com/Angstrom-distribution/setup-scripts.git
cd setup-scripts
./oebb.sh config beaglebone
MACHINE=beaglebone ./oebb.sh bitbake systemd-image

After the process is completed you should have under setup-scripts/build/tmp-angstrom_v2012_12-eglibc/deploy/images/beaglebone the files needed that should be put in the microSD (use mkcard.txt for that purpose).

More information:

 

Standard

ROS in Ubuntu ARM

So just before I dive into the Beagle-ROS using the meta-ros project (ROS in an OpenEmbedded Linux System) i wanted to try how difficult it was to set up ROS on an ARM board (BeagleBone) running Ubuntu 12.10. For some time, the UbuntuARM instructions have been in the ROS page but I didn’t have the time to test it out. I followed the instructions but i ended up stucked at point 1.4. When I try to install ROS libraries or tools:


install ros-groovy-ros ros-groovy-roslib ros-groovy-rospack
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
ros-groovy-rospack : Depends: libboost-filesystem1.46.1 (>= 1.46.1-1) but it is not installable
Depends: libboost-program-options1.46.1 (>= 1.46.1-1) but it is not installable
Depends: libboost-system1.46.1 (>= 1.46.1-1) but it is not installable
E: Unable to correct problems, you have held broken packages.

And of course these dependencies can’t be installed through apt-get so it seems it’s not that straightforward actually.

Seem a lot of people might benefit from this project ;).

Standard